News Problem with Client (8.0.2) [проблема решена]

Status
Not open for further replies.
L

Liightman

Guest
#1
Hi everybody

Hi, have a problem with the client when i try to connect, here is the error



And the error on AccountServer

I do not understand why I have this error, the server is in 4.0.2 too ...

Thanks
 
М

Мимино

Guest
#2
He writes in the log: "Wrong version of the client." Means either the client is not 4.0.2, or the client has incorrectly changed.
 
E

Ellsion

Guest
#6
Hm, server version 4.0?
Because problem with serialization of factions objects.
 
L

Liightman

Guest
#7
Here is the actual version

From where the problem can come from ?

Thanks
 
L

Liightman

Guest
#9
Only the TimeCheckerEmu.jar to edit the listening adress, but nothing else
 

Сорок два

Administrator
Staff member
#10
Try with an original TimeCheckerEmu.jar to start the server and to enter a game.
To run both locally and a network server, you do not need to modify the TimeChecker!

Sorry to the my bad english :/
 
L

Liightman

Guest
#11
I tried with the original US GALA server, but still the same error, so I tried to fix this error by editing the server version (48) by the client version (78).
So this error doesn't appear anymore, now it's a new error :


I don't know where the error come from, I really need help ! Thanks :)
 
E

Ellsion

Guest
#12
I tried with the original US GALA server, but still the same error, so I tried to fix this error by editing the server version (48) by the client version (78).
So this error doesn't appear anymore, now it's a new error :


I don't know where the error come from, I really need help ! Thanks :)
Java version?
 
E

Ellsion

Guest
#14
Are you sure that all okay with xml database file system and with mysql / pgsql database? Including with accounts / characters. Because something is wrong with factionCount array.
The error is obtained when MsgFrondEndStats class trying to read SerializationDataInput.
In this case count of bytes more than 32 and then java throw SerializationException.
 
L

Liightman

Guest
#15
I tried with an oldest version of pgsql (i was using 9.2 and try now with 9.1)
But still an error :
 
R

rehm

Guest
#16
Running in localehost produces the same error?
Check in localhost ...
Probably where that an error ip. ..
 
L

Liightman

Guest
#17
Cannot try in localhost because I use an ubuntu server, so I can't run locally the game :/
 
R

rehm

Guest
#18
Somewhere on the forum, I left the launch files on Linux. Look.
 
R

rehm

Guest
#20
Oh no ... starting the server ... the client runs through wine
 
Status
Not open for further replies.